PowerPoint 2010 makes work flows more efficient, effectively uses web applications to make your work available anywhere, and makes collaboration with others much easier. Here are some of the new features from PowerPoint 2010.

Directly Insert Videos from Files
You can now directly insert a video from your file to your presentation. To do this:

  1. Click the Insert tab on the ribbon menu
  2. Then select Video, under the Media section, and select Video from File under the dropdown menu
  3. Select the video you wish to use, and click Insert to add the video to your presentation

Directly Insert Videos from Online
PowerPoint 2010 supports embedding video from online video sites like YouTube. To insert a video from online:

  1. Click the Insert tab on the ribbon
  2. Then select Video, under the Media section, and select Video from Website under the dropdown menu
  3. You will see the Insert Video from Online Video Site dialog box, copy and paste the embedded HTML code into the box that appears
  4. Click Insert button and the video will be added to your presentation
  5. When you want to show your presentation make sure your computer is connected to the internet

Edit Embedded Video
PowerPoint 2010 enables a user to edit embedded video right from PowerPoint itself without using an external video editing program. To edit an embedded video:

  1. First, click on a video that’s been embedded into a slide
  2. Then, click the Format tab to edit the video’s brightness, contrast, color, and style
  3. Click the Playback tab, all of the video editing tools display. Once you edit the video, you can compress it to lessen the presentation’s file size

Create a Video of Your PowerPoint Presentation
After you have created a PowerPoint presentation, you can directly create to a video with WMV format by default. To create a video:

  1. Click the File menu option, then choose the Save & Send option
  2. Click Create a Video under File Types section
  3. Once, you have formatted your settings, click the Create Video button

New Animation Tools
PowerPoint 2010 offers a user friendly thumbnail type of style choices. Just by looking at each choice, you would know what the effect will do when you apply it. To apply an animation to your presentation:

  1. Click on the Animations tab on the ribbon
  2. With your image selected, you can place your mouse over the different animation styles to preview the effect on your image
  3. Once you have found an animation you like, select it to apply it to your image

New 3D Transitions
PowerPoint 2010 includes many new slide transitions, thus it empowers you to create a more powerful and eye-catching presentations. To apply these transitions to slides:

  1. First, select the slide you wish to apply the transition to
  2. Then click on the Transitions tab on the ribbon menu
  3. Click on the different styles of transitions to preview them with your slide

Broadcast Your PowerPoint Presentation
PowerPoint 2010 makes sharing and connecting easier than before, allowing users to remote share presentations with users from anywhere in the world. It even allows movie sharing to users, even if they don't have PowerPoint installed. To broadcast your presentation:

  1. Click on the File menu
  2. Then select Save & Send
  3. Choose the Broadcast Slideshow option under the Save & Send menu
  4. Click the Broadcast Slideshow button to broadcast your show

Turn Your Mouse into a Laser Pointer
PowerPoint 2010 now allows you to use your mouse as a laser pointer during presentations. To use this feature:

  1. First, launch your PowerPoint presentation
  2. Hold down the Ctrl key
  3. Then, click the left mouse button anywhere on the slide
  4. The pointed arrow will automatically turn into a laser pointer on the slide

For an extensive list of new and improved features of Microsoft Word 2010, please go to the following Microsoft page: What's new in PowerPoint 2010.

 

Article number: 
1600
Last updated: 
September 10, 2012