Here is a look into some of the new features of Microsoft Excel 2010.

Sparklines
Sparklines are tiny charts that fit into a single cell in a worksheet. Sparklines are intended to give you a quick look at trends or changes that may not be easily spotted in the data itself. There are three types of sparklines available in Excel 2010:

  • Line Sparklines
  • Column Sparklines
  • Win/Loss Sparklines

Improved PivotCharts
It is now easier to interact with PivotChart reports. It's easier to filter data directly in a PivotChart and to reorganize the layout of a PivotChart by adding and removing fields. Similarly, with a single click, you can hide all field buttons on the PivotChart report. To insert a PivotChart:

  1. Click on the Insert tab
  2. Then select the PivotTable button under the Tables section
  3. From the dropdown menu select, PivotChart

Slicer
Slicers are visual controls that let you quickly filter data in a PivotTable in an interactive way. If you insert a slicer, you can use buttons to quickly segment and filter the data to display just what you need. You no longer have to open a list to see which filters are applied to the data. Instead, it is shown there on the screen in the slicer. To use a slicer:

  1. Click on the Insert tab
  2. Then click on the Slicer button under the Filter section

PowerPivot for Excel add-in
With PowerPivot for Excel, you can import millions of rows of data from multiple data sources into a single Excel workbook, create relationships between heterogeneous data, create calculated columns and measures using formulas, build PivotTables and PivotCharts, and then further analyze the data so that you can make timely business decisions.

More Memory
Excel 2010 has released a 64 bit version which will allow for more memory capacity than the current 2 GB limitation. This means that users can create bigger, more complex workbooks.

Access Spreadsheets from Anywhere
Just post your Spreadsheets online and access them from anywhere. You can view or edit them from any computer or Windows phone. To save your spreadsheet to the web:

  1. Click on the File tab on the ribbon menu
  2. Then click on Save & Send
  3. Select the Save to Web option under the Save & Send menu

For an extensive list of new and improved features of Microsoft Excel 2010, please go to the following Microsoft page: What's New in Excel 2010.

Article number: 
1607
Last updated: 
September 10, 2012